0
\$\begingroup\$

I apologize in advance, I'll try and explain this the best i can, but i really don't know what's causing this.

I have a project I'm building for UWP, I'm using Stripe IAP for in app purchases. The plugin works 100% in the editor, and even on a stand alone build, but if i build it to UWP, it just breaks. There's no errors or anything. The button that's supposed to open the browser and initiate a purchase, it doesn't open the browser, it just does nothing.

I've tried it in Debug mode and there's an error relating to the "Get method" not being found, after some investigation, this is occurring in a stripe script built into metadate, but it definitely does have a get method...

https://drive.google.com/file/d/1N737CgdhWZ7Mm2c2b1veUuBjs8C25eQD/view?usp=sharing

Here's a zip with two videos in a zip showing it working in the editor and it broken in UWP(i've tried master, release, debug, nothing works). Is there some permissions or something that need to be enabled? I, as a test, tried enabling all the permissions in the player settings, but that did nothing. Also, i know it's nothing related to the browser pop up, i tested opening the browser with another script and it worked.

Thanks, sorry i'm not sure what other info to provide. Hope someone has some insight.

\$\endgroup\$
2
  • 1
    \$\begingroup\$ When you say "in the editor", do you mean the Unity editor? If so, don't forget to tag your question unity, or the corresponding tag for whatever tech stack you're using. Note that users will not download your entire project just to troubleshoot, so instead of providing a download link, you should ensure your question contains the instructions required to reproduce a Minimal Complete Verifiable Example of the problem, starting from a new, empty project. \$\endgroup\$
    – DMGregory
    Sep 17, 2023 at 19:36
  • \$\begingroup\$ @DMGregory Ah, sorry. Thought I put Unity in the title. I attached 2 videos in a zip, not the project. \$\endgroup\$
    – Mashimaro7
    Sep 18, 2023 at 5:06

0

You must log in to answer this question.

Browse other questions tagged .