2
\$\begingroup\$

In the Unity High Definition Rendering Pipeline, when adding Volumetric Fog, there's a checkbox to enable the Volumetric Fog, and then there's an additional checkbox to the right of it that also has to be checked to enable it. Why is there the second checkbox? It feels a bit redundant.

Image showing the second checkbox for Volumetric fog

Initially, I didn't have the second checkbox checked (indeed, I'm not certain it was initially visible), and the Volumetric fog simply did not work. I just ran into someone else who had the same problem.

\$\endgroup\$
2
  • \$\begingroup\$ Please edit the question to limit it to a specific problem with enough detail to identify an adequate answer. \$\endgroup\$
    – liggiorgio
    Commented Aug 10, 2023 at 0:01
  • 1
    \$\begingroup\$ @liggiorgio: I'm not certain how to make it more specific and detailed than "why are there two checkboxes for the same thing?" :) \$\endgroup\$ Commented Aug 10, 2023 at 1:08

1 Answer 1

3
\$\begingroup\$

I also posted this question on the official Unity forums, and received the following response:

The left checkbox you are talking about is used for overriding any value from the default value. If that checkbox isn't ticked, that means you don't want to override it, and Unity will just use the values from the default Volume Profile Asset.

In your case, it seems like Volumetric Fog is turned off in your default Volume Profile Asset. You then added an override volume, said "I want to override this" by ticking the left checkbox, and then overrode the default value by ticking Volumetric Fog on.

In essence, the left checkbox is "I want to override this", and the checkbox to the right of that is what you want the override to be.

You can see your default Volume Profile Asset settings in Edit -> Project Settings -> HDRP Global Settings.

\$\endgroup\$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .