0
\$\begingroup\$

I was working on some test project since I'm beginner in unreal engine, and I suddenly started getting this:

The project could not be compiled. Would you like to open it in Rider?

Running C:/Program Files/Epic Games/UE_5.1/Engine/Build/BatchFiles/Build.bat Development Win64 -Project="D:/rough/UnrealEngine/MyGame/MyGame/MyGame.uproject" -TargetType=Editor -Progress -NoEngineChanges -NoHotReloadFromIDE
Running UnrealBuildTool: dotnet "..\..\Engine\Binaries\DotNET\UnrealBuildTool\UnrealBuildTool.dll" Development Win64 -Project="D:/rough/UnrealEngine/MyGame/MyGame/MyGame.uproject" -TargetType=Editor -Progress -NoEngineChanges -NoHotReloadFromIDE
Log file: C:\Users\baga\AppData\Local\UnrealBuildTool\Log.txt
Creating makefile for MyGameEditor (no existing makefile)
Expecting to find a type to be declared in a module rules named 'RD' in UE5Rules, Version=0.0.0.0, Culture=neutral, PublicKeyToken=null.  This type must derive from the 'ModuleRules' type defined by Unreal Build Tool.  

I've done what I could, including reinstalled visual studio and its dependencies, reinstalled unreal engine itself, but this doesn't go away. It always pops this error when i create a blank/non-blank c++ project in unreal engine.

When I compile the solution from visual studio, I get these error:

Microsoft.MakeFile.targets(44, 5): [MSB3073] The command ""C:\Program Files\Epic Games\UE_5.1\Engine\Build\BatchFiles\Build.bat" MyGameEditor Win64 Development -Project="D:\rough\UnrealEngine\MyGame\MyGame\MyGame.uproject" -WaitMutex -FromMsBuild" exited with code 6.  

Not sure what is causing the issue, but, I'm literally not being able to start anything. Any insight would be really helpful. Thanks in advance.

\$\endgroup\$

2 Answers 2

1
\$\begingroup\$

The bug definitely seems to be from the Rider link plugin. However, many posts suggested uninstall it, but, in my case, I had only uninstalled it from the plugin menu in UE. That somehow didn't work. So, I manually deleted the RiderLink and RiderCodeAccess folder from the unreal engine installation folder,typically under C:\...\Epic Games\....\Plugins\Developer.

However, after you do this, UE doesn't list rider as your source code editor. In that case, completely reinstall the rider link from unreal engine, or, after you open the solution file from rider, it gives you option to install rider link. But, you'd also require the RiderSourceCodeAccess folder. I suggest you directly follow the instruction from github, and install it in project:

- Get the source code of the main branch;
- Unzip RiderSourceCodeAccess.zip to RiderSourceCodeAccess folder;
- Copy RiderSourceCodeAccess folder to {GameProjectRoot}/Plugins/Developer; a. If {GameProjectRoot}/Plugins/Developer does not exist, create it;
(For Windows and .sln project model only) Re-generate solution files - uproject file > context menu > Generate Visual Studio project files;
- Build UE project using Rider (or any other IDE that you've setup for your OS);
- Start Unreal Editor;
- Edit > Editor Preferences ... > General > Source Code > Source Code Editor;
- Select Rider from drop down list. NB: only Rider with C++ plugins will be available from drop down list.
\$\endgroup\$
0
\$\begingroup\$

This is happens when you have Unreal open and you try to compile from Rider (or Visual Studio). In order to compile from Rider (or Visual Studio) you need to first close unreal.

\$\endgroup\$
2
  • \$\begingroup\$ No, this happens, while creating the project itself, not after I've written something and try to compile the code \$\endgroup\$
    – mleu
    Apr 6, 2023 at 16:44
  • \$\begingroup\$ Try this stackoverflow.com/a/68086264/13407948 \$\endgroup\$ Apr 7, 2023 at 1:09

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .