2
\$\begingroup\$

When starting my game for debugging, I'd like to have the game pop up at my second monitor (still in "Windowed" mode), instead of on top of the Godot editor window itself. I've tried several things to get this to work:

  • Drag the debug window to another screen, restart it (hoping it'd "remember" its last position)
  • In Project Settings under Display, Window: try "Primary Screen Center" with 0, 1, 2 for "Initial Screen"
  • In Project Settings under Display, Window: try "Other Screen Center" with 0, 1, 2 for "Initial Screen"
  • Same as above but now with "Fullscreen" (which I don't want, but just for testing purposes)
  • Same as above but now with the Godot editor on my other monitor
  • Search Project Settings for "Monitor" and "Screen" to find other related options
  • Go through all options in the "Debug" menu (none seem relevant)

None of these worked. Which probably means I'm doing something wrong because "Other Screen Center" should at least have some effect, according to the tooltips even exactly the effect I'm looking for?

I've tried searching online but I mainly land on "Multi-monitor editor support" or similar threads. Although that feature would also be nice, I don't need full multi-monitor and floating window support for the editor; just the game needs to go to my second monitor.

I'm running Godot 4.0 on Windows 10 Pro x64, and have two 2560x1440 monitors.

\$\endgroup\$

1 Answer 1

9
\$\begingroup\$

Look in the "Editor" menu, option "Editor Settings...", then Run > Window Placement > Screen.

\$\endgroup\$
2
  • \$\begingroup\$ btw,Fristly I tried and failed to find the answer too, then post on godotengine's QA. other answer it, I tried & it works. \$\endgroup\$
    – jzq
    Mar 29, 2023 at 2:41
  • \$\begingroup\$ Perfect! Thank you for taking the time to post an answer. I had not realized there were also "Editor Settings" when I wrote the question, only knew about the "Project Settings". This is exactly what I needed. \$\endgroup\$
    – Jeroen
    Mar 29, 2023 at 7:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .