All I get from this setting is a single image. I'm not sure why the Frame Interval and Time Interval Recording modes won't work. Every other option works, including the Movie and Animation Clip options.

I've read the documentation extensively and it seems like these frame modes should be straightforward.

Anyone know why this might not work (or why my current configuration could be problematic? The only thing I can think of is that the recorder is overwriting each file frame, but it isn't clear how to fix that. "Verbose mode" didn't show anything unusual either.

Unity Recorder screenshot and settings

  • 1
    \$\begingroup\$ "The only thing I can think of is that the recorder is overwriting each file frame, but it isn't clear how to fix that" — Did you try adding the <Frame> wildcard to the output file name using the wildcards dropdown? \$\endgroup\$
    – DMGregory
    Jan 20 at 22:30
  • \$\begingroup\$ Tried it with luck shortly before I saw your comment. As you said, a FRAME number has to be added to the Output File Name prevent overwriting. That's not very intuitive. Must be a Unity oversight. Do you mind adding this as an answer? \$\endgroup\$
    – MXMLLN
    Jan 20 at 22:55
  • \$\begingroup\$ You beat me to it, so feel free to add your own answer showing how you solved it. As for intuition... how did you intuit that you'd be able to tell the files apart, without the frame number in the file name? \$\endgroup\$
    – DMGregory
    Jan 20 at 23:05
  • \$\begingroup\$ I was thinking we solved this at the same time. I was still looking for a solution to my problem when I found the answer, while you went out of your way to help me. \$\endgroup\$
    – MXMLLN
    Jan 21 at 7:10
  • \$\begingroup\$ Obviously Unity could have done a lot of things. They could have increased the Take number with every frame, for instance. They also could have automatically added a Frame wildcard, which the user might expect when they selected a multi-frame Recording Mode \$\endgroup\$
    – MXMLLN
    Jan 21 at 7:13

1 Answer 1


The <Take> wildcard in the file name will increment once for each recording session, helping you distinguish attempt #1 from attempt #50 at recording the same sequence.

If you've selected a video format as your output, that's enough. All the frames for a given take get packed into the same single video file.

But when you switch to outputting a still image, just a <Take> number isn't enough: now we need a separate file name for each frame, so saving the next frame doesn't overwrite the previous.

You can click the "+ Wildcards" drop-down to add a <Frame> wildcard to your filename, or type it out yourself. This will increment for every frame in a take, keeping the latest frame from overwriting the previous, and ensuring that you can later reassemble the frames in the right order.

Unity doesn't add this automatically because it doesn't know where in the file name you want it. Many game studios use pipeline tools that expect a very specific file naming convention to work, so having Unity automatically alter the text in that box when you change another setting somewhere else in the dialog would be an easy way to get sneaky bugs that silently break your pipeline.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .