3
\$\begingroup\$

I've been having a lot of trouble getting tiles to have collision in the newest Godot 4 beta10.

I thought there was supposed to be a physics tab that would give collision options like in previous betas, but maybe that was removed?

This is what I see:

\$\endgroup\$

1 Answer 1

4
\$\begingroup\$

The way you edit tile collision shapes has changed in Godot 4.

  1. First click the TileSet assets in the tilemap inspector, and additional editing options appear.

enter image description here

enter image description here

  1. Add elements in the Physics Layers tab.

enter image description here enter image description here

  1. The physical layer you just added will appear in the Paint tab, click it.

enter image description here

  1. Then you can edit the collision information of this physical layer, hope this helps.

enter image description here

\$\endgroup\$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .