1
\$\begingroup\$

I have no idea why I have blurry/transparent borders on sprites when I cut them in the Sprite Editor, whereas I get everything fine in a graphic editor.

Picture from Sprite Editor with a problem:

enter image description here

Picture from the graphic editor (everything looks fine):

enter image description here

My Unity settings:

enter image description here

\$\endgroup\$
0

1 Answer 1

1
\$\begingroup\$

You've set the "Max Size" for this texture in the import settings to 2048, and asked Unity to automatically resize the image using the Mitchell algorithm if it's larger than this:

Import settings showing max size

But your sprite editor shows that you have a sprite at a position some 500 pixels past this maximum cutoff, out around 2560 pixels from the far edge:

Sprite editor showing sprite farther than 2048 from origin

So it looks like your image is larger than the max size you've asked for. That means Unity will do exactly what you told it you wanted: downsample the image to 2048x2048 using the Mitchell algorithm, which includes blending adjacent pixels, creating partial translucency.

To fix this, author your sprites within your max size budget so that Unity does not have to scale them down, or increase the max size setting you're using on import so that it accommodates the image's authored size.

\$\endgroup\$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .