0
\$\begingroup\$

I built a Unity AR app which worked on my phone. However, on sharing the APK to another phone with the same Android version, it crashes on startup. I've tried increasing the target API level to max, and using Developer Mode for the other phone, but it still crashes. All the versions work on my phone. What is the problem here?

\$\endgroup\$
3
  • \$\begingroup\$ We'll typically need a Minimal Complete Verifiable Example to be able to diagnose this. Try making a copy of your project, and deleting as much as you can from it while keeping the problem present. Or start a new, empty project, and add stuff from your current project to it until the problem re-appears. Doing this experiment, you can narrow down the minimal set of factors that might be involved, and update your question to give us the steps to reproduce the problem. Once we can reproduce it, we can test potential fixes to be sure they'll work for you. \$\endgroup\$
    – DMGregory
    Commented Oct 18, 2022 at 9:59
  • \$\begingroup\$ @DMGregory I was able to figure out the fix (needed to change encoding and include Armx64). Do I delete this problem now? \$\endgroup\$
    – Apocalypse
    Commented Oct 19, 2022 at 13:53
  • \$\begingroup\$ It would be better to post an Answer below, so it can help other developers searching for solutions to similar problems. Including details about how you diagnosed the issue can also help, and attract more search hits. \$\endgroup\$
    – DMGregory
    Commented Oct 19, 2022 at 14:46

1 Answer 1

1
\$\begingroup\$

So, I fixed this by going to Build Settings >> Player >> Other Settings >> Scripting Backend and changing it to IL2CPP as well as including ARMx64 in the target architecture. The basic problem was that ARMx64 architecture wasn't included, which is needed for some phones.

\$\endgroup\$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .