0
\$\begingroup\$

I have Save/Load functionality where I use LoadGameFromSlot, SaveGameToSlot and SaveGame object. When I use it inside the UE4 editor - everything works fine. But when I make a package and launch it as a separetee game - it don’t work.

For example I save game on Level_1, then open Level_2 and load saved game. After load is finished - player teleports outside of the map. I checked - values of all variables including palyer location was saved and then it was loaded correctly.

Can’t understand, what is wrong. I tried to make different packages but error is still there.

Here you can see values of the variables when I press Load button after level was loaded for both versions - wich I launch from UE4 and from the package. It is the same

enter image description here

So now I removed all load logic and only try to place player to zero location, but it still don’t work. I execute it on BeginPlay

enter image description here

\$\endgroup\$
2
  • \$\begingroup\$ Please edit your question to walk us through the steps to create a Minimal Complete Verifiable Example of the problem. Once readers can reproduce the issue, they can test potential fixes to be sure they'll work for you, helping you get more accurate answers, faster. \$\endgroup\$
    – DMGregory
    Commented Aug 14, 2022 at 21:18
  • \$\begingroup\$ @DMGregory I have updated question \$\endgroup\$ Commented Aug 15, 2022 at 8:51

0

You must log in to answer this question.

Browse other questions tagged .