1
\$\begingroup\$

I want my sprite to use a blend mode based on the background (like in Adobe programs) so I set shader graph blend mode to Multiply. The blend works, but I get strange artifacts on my sprite.

Unity screenshot

In this picture, you can see how sprite looks in scene, the graph, preview, and sprite settings.

Here is my texture:

enter image description here

\$\endgroup\$
0

1 Answer 1

2
\$\begingroup\$

Lerp the colour to white in the transparent areas.

Lerp node taking (1, 1, 1, 1) as the first parameter, texture colour as the second, and texture alpha as the third

Multiplying by white (1) is the same as doing nothing at all, so this mimics traditional alpha transparency.

It appears that the alpha value is ignored by default in the multiply blend mode, so this change bakes the effect into the colour channel instead.

\$\endgroup\$
0

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .