0
\$\begingroup\$

When I add a light in the scene then the light will show on the ground, but when I add a second light, neither of them show on the ground.

One light:

One light's hot spot on a white ground plane

Add second light:

Ground plane with no hot spot

My light is a spot light, and it's not working on the iOS device, but the PC is working fine.

I found this is related to quality settings: when I change to high, it shows both lights.

Is there a way to show two lights while using medium quality?

\$\endgroup\$
3
  • \$\begingroup\$ Did you set Render Mode of the second light to Important? And did you set pixelLightCount in Project Setting -> Quality? \$\endgroup\$
    – Mangata
    Aug 1 at 7:22
  • \$\begingroup\$ @Mangata I think you could expand this into an answer showing the settings you'd recommend. \$\endgroup\$
    – DMGregory
    Aug 1 at 12:35
  • \$\begingroup\$ Depending on your target look for the game, there may be ways to achieve that look that will run faster / consume less battery than increasing the pixel light count. If you find your game is not running as well as you'd like with multiple lights, try posting a question showing your visual target and asking for an efficient way to achieve it. \$\endgroup\$
    – DMGregory
    Aug 1 at 14:32

1 Answer 1

0
\$\begingroup\$

Renderer - pixelLightCount , Medium is 1 and if you want more light show on the ground then set the number to more than one.

\$\endgroup\$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .