2
\$\begingroup\$

I created an Object in Blender and it looks fine in it.

Object in blender

These are the vertex normals:

vertex normals

These are the surface normals:

surface normals

However, after importing in Unity, the emission color looks entirely distorted:

object imported in unity

I tried to adjust settings in the directional light panel, but I'm still not able to get visuals that look as above. Is there any other setting in Unity that can help to achieve results as the 1st picture? (I inserted a color script on all the white segments so that they turn yellow at runtime).

\$\endgroup\$
3
  • 1
    \$\begingroup\$ in blender, check which way your normals are pointing, I suspect you have inverted normals. \$\endgroup\$
    – Jack
    Mar 20, 2022 at 23:18
  • \$\begingroup\$ As @Jack said check normals, and also if I remeber correctly, blender's cycles allows you to use nodes materials which are not supported in unity, lastly check color space in unity, changing to linear might help \$\endgroup\$ Mar 21, 2022 at 6:50
  • \$\begingroup\$ I updated the picture of normal. I just started blender so not entirely sure if the normal of the vertex looks ok? Changing the color space to linear does not help much but changing environment lighting source to "color" shown a much better result. \$\endgroup\$
    – chuackt
    Mar 21, 2022 at 14:13

1 Answer 1

2
\$\begingroup\$

Normals and tangents of your model may differ between Unity and Blender due to import settings. In the Model Import Settings window in Unity, you can find an option to re-calculate normals for the model on import.

From the docs:

You can exercise control over how Unity handles the Normals and Tangents in your Model with the Normals, Normals Mode, Tangents, or Smoothing Angle options.

Try to force importing source normals, or tweak the settings to re-compute normals within Unity until you get the desired results.

\$\endgroup\$
2
  • \$\begingroup\$ Thank you!! After calculate the normal and adjust the lighting setting to gradient, it look even much beautiful \$\endgroup\$
    – chuackt
    Mar 22, 2022 at 1:46
  • \$\begingroup\$ @chuackt Whether you want smooth of flat shading is actually something you can decide in Blender on a face-by-face basis. this allows you to create objects which have both round and angular parts. \$\endgroup\$
    – Philipp
    Mar 22, 2022 at 11:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .