I am having a problem with the Unity Editor. It hangs for a fraction of a second about once per second. I took a video recording of me walking through the default hdrp scene. https://youtu.be/Uz2B85Mq0QE

It's definitely cyclical, every second or so the computer just hangs for a fraction of a second. In the video above, notice how even when I'm not running the Unity scene, my cursor turns into the windows spinning blue circle cyclically every second, just like how the game hangs.

I've tried everything I can think of including disabling antivirus/firewall software, changing the external script editor, etc... I reproduced the bug on more than 1 version of Unity including both LTS and Beta versions. I know it's not my specs, I have an Intel i7-11700K with 16GB of RAM and an Nvidia 3070.

I also ran the Unity Profiler and the task manager and collected the output of these processes in this video https://youtu.be/GHgqP5A3bYE. From the start of the video until the 0:44 mark is the Unity Profiler and from 0:44 until the end is the task manager.

Just for quick reference here is the screenshot of the Unity Profiler clearly indicating extreme cyclical activity spikes.
enter image description here

What is the problem? What could be causing this?

  • \$\begingroup\$ If I'm reading that correctly, you're getting a massive spike in garbage collection. The Garbage Collector [GC] is used to clean up any objects (gameobject, classes, etc) that are no longer being used. More info here: docs.unity3d.com/Manual/…. Garbage collection happens "every so often" either on a clock or when the system needs more memory. Try to reuse classes and objects. \$\endgroup\$
    – Basic
    Feb 23, 2022 at 1:41
  • 1
    \$\begingroup\$ Oh that's interesting but I still don't really get why that's happening. I am only running the default scene for Unity's HDRP pipeline. I haven't changed anything in this scene \$\endgroup\$ Feb 23, 2022 at 2:04

1 Answer 1


I fixed it. The problem was coming from the plugin Github for Unity. I deleted the folder Assets/Plugins/Github and the problems disappeared.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .