I have 3 main assemblies, Core, Character, and Interactable. Interactable and Character both depend on Core. I got an error saying I needed to add TMPro as a dependency for Core, so I did that, and all was right with the world. But when I got the same error with InputSystem I went down a rabbit hole of old forum posts that led to no meaningful results.

I have tried:

  • Reinstalling InputSystem
  • Regenerating the Project Files
  • Relaunching Rider
  • Relaunching Unity
  • Removing Rider as the default IDE, and re-adding it
  • And most of these in combination with each other

I also don't know exactly what to post, as none of the errors seem to be in my code, it seems to be in my project settings. Here's the full error message:

Assets\Scripts\Character\PlayerController.cs(3,19): error CS0234: The type or namespace name 'InputSystem' does not exist in the namespace 'UnityEngine' (are you missing an assembly reference?)
Assets\Scripts\Character\PlayerController.cs(66,29): error CS0246: The type or namespace name 'InputValue' could not be found (are you missing a using directive or an assembly reference?)

Thanks for any and all help!


1 Answer 1


So, this is dumb, I ended up figuring it out.

I didn't have to include InputSystem in Core, I had to include it in Character. I don't know why I was selecting the wrong one. So, double-check if it's actually the assembly you think that needs the dependency, and don't always trust what file gets opened when you double click the error.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .