1
\$\begingroup\$

I use Blender to model walls. I render 2d sprites of these walls in a (gaming) isometric perspective.

My problem pertains to the "edges" of the 3d wall:

enter image description here

On both left and right ends of the frontal plane of the wall, I get 1 pixel vertical lines that are brighter than their neighbour pixels. This happens to all of my walls.

In the 2d iso world, when I place two sprite walls next to each other, I get a visible vertical line between the walls:

enter image description here

I tried to increase the 2d sprite width by 1px but then I lose the pixel-perfect grid alignment, depending on the wall texture, you see that they are overlapping too much, and have some ugly overlap when I build wall corners.

Then I thought the brightend-up edges of the walls are caused by the scene light in Blender. Eventually, I turned off the light. There is still a visible vertical line:

enter image description here

So worst case: I do not know the cause or a solution (other than manually editing each 2d sprite).

\$\endgroup\$
2
  • 2
    \$\begingroup\$ This looks like something you might want to ask about on the Blender StackExchange. It looks to me like your sprites have a subtle anti-aliasing applied to the edges, so the column of pixels right along the edge is not quite opaque, showing a hint of what's behind through. You may need to adjust the alignment of the walls when rendering them to a sprite to ensure they fully cover the last column of pixels on both sides. \$\endgroup\$
    – DMGregory
    Dec 15 '21 at 12:54
  • 2
    \$\begingroup\$ I’m voting to close this question because it would be best answered on the Blender SE. \$\endgroup\$
    – liggiorgio
    Dec 15 '21 at 12:58

You must log in to answer this question.

Browse other questions tagged .