When I am using CursorMode.ForceSoftware the shade of the cursor changes and appears much darker than it is supposed to be.
I have tried all the available 'Formats' and they all result in the same issue.

This problem ONLY occurs when I use CursorMode.ForceSoftware (which I need, because I need the cursor to be larger than Auto allows, to my understanding). However, when using cursor mode Auto, the colour displays as it should.

This is what the cursor looks like as compared to what it should look like:

enter image description here

Does anyone have any idea how to fix this?

After some further investigation I am fairly sure that the problem has to do with the fact that I changed the project settings from the default gamma colour space to linear colour space.

Changing 'texture type' from cursor to default, and deselecting sRGB (color texture) causes the texture to display correctly, however this option is only available for the default texture type and there is no way to do this while using it as a cursor.

I hope that is enough of a clue as to what is going on for someone to be able to help out.



You must log in to answer this question.

Browse other questions tagged .