2
\$\begingroup\$

This is a super basic question, but I have absolutelly no clue why there is no collision and the player continues to fall. Im following FreeCodeCamp(minute 37:20). This is what I have: enter image description here What is Happening?

\$\endgroup\$
3
\$\begingroup\$

Check the Layer Collision Matrix of your Physics 2D project settings to make sure the "Default" layer reacts to itself. I've seen this mysteriously get turned off before.

To access this, Go to Edit > Project Settings… then click on the Physics 2D label on the left. The Layer Collision Matrix is at the very bottom of the list of settings. This matrix controls whether layers react to other layers, including themselves.

Phyics layer settings

\$\endgroup\$
4
  • \$\begingroup\$ Could you provide me a path to follow? Since I'm new, Im stuck a bit \$\endgroup\$
    – Roman
    Oct 20 at 21:44
  • \$\begingroup\$ Edit > Project Settings… . Then Physics2D tab. The layer matrix is way down at the bottom of the window. \$\endgroup\$ Oct 20 at 21:46
  • \$\begingroup\$ There is a lot of things unmarked, should I mark all of them? \$\endgroup\$
    – Roman
    Oct 20 at 21:53
  • 1
    \$\begingroup\$ Sure. Just make sure the check mark that lines up between the "Default" row and the "Default" column is checked. \$\endgroup\$ Oct 20 at 21:54

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.