0
\$\begingroup\$

I had a project on Unity and I used 2020 version of Unity. Then my colleague pulled my project from the github and tried to open it with 2021 version of Unity. The project was redone for the 2021 version and everything seemed to work well. Then he tried to close Unity, as usual a quitting window came out. I said it usually doesn't take very long. But it turned out that it took a long time. He decided to leave it for the sake of experiment and so it worked for about 70 hours. What could have gone wrong? Why is Unity not closing?

enter image description here

\$\endgroup\$
3
  • \$\begingroup\$ Can you walk us through the steps to create a Minimal Complete Verifiable Example? If you make a new, empty Unity project in v 2020, sync it from GitHub, then open it in v 2021 and close it, do similar symptoms occur? Or does some script or other content from.your original project need to be included to replicate this issue? Does the same issue happen if your colleague re-opens their 2021 version and closes it a second time? \$\endgroup\$
    – DMGregory
    Oct 4 at 11:01
  • \$\begingroup\$ I've seen this too. My first guess is there is a Unity 2020 bug. My second guess is there is a thread that isn't getting terminated. \$\endgroup\$
    – Evorlor
    Oct 4 at 15:54
  • \$\begingroup\$ Certainly this would appear to be a bug and should be reported to Unity for resolution. Info on reporting bugs from the editor or hub here: support.unity.com/hc/en-us/articles/… \$\endgroup\$ Oct 4 at 23:48

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.