0
\$\begingroup\$

Unity debugger plugin and C# plugin are installed but Visual Studio Code does not recognize Unity APIs. Intelisense does not work. How can I fix?

enter image description here

\$\endgroup\$
1
1
\$\begingroup\$

I had the same problem happen to me several times in my last project. You should first check the usual solution : Go to Preferences -> External tools and set vs studio as external script editor (of course make sure that in visual studio you have Tools for unity installed.) Now if that is already set, witch probably is, you can click Regenerate project files that fixed it for me.

\$\endgroup\$
1
  • \$\begingroup\$ I believe it should be changed to "Visual Studio Code" in Preferences -> External tools. Regenerating the project files as a first check is a good idea. Also, make sure you have the Visual Studio Code tools package installed in Unity. Visual Studio Code will need the Unity Extension installed as well. And finally, if you run into issues with dotnet/mono, make sure you have the latest installed for those as well (there are stack exchange questions with information on this) \$\endgroup\$ Oct 14 at 15:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.