1
\$\begingroup\$

The first image below shows my mesh in Blender with the Blender lighting, and the second image from inside UE4 has this weird shading on it. Is there any way to help it look like the first image? I've tried two-sided lighting, increasing the lightmap resolution, nothing seems to fix it. If anybody knows a fix, please let me know. Thanks! :)

EDIT: Turning off my exponential height fog seems to get rid of the shadows, but I really need the fog for the game. So if anybody knows how to fix this without getting rid of the fog, please let me know. :)

enter image description here

enter image description here

\$\endgroup\$
4
  • \$\begingroup\$ I am not sure what you mean. Most of what looks "wrong" to me in the second image are JPEG artifacts (when it comes to demonstrating rendering issues, then you might want to post PNG screenshots instead). Or maybe it's "too yellow" due to the environment mapping from the yellow surrounding? Did you try putting it in a more neutral environment? \$\endgroup\$
    – Philipp
    Aug 17 at 15:40
  • \$\begingroup\$ @Philipp Hi! Sorry for the late response. I've tried turning off different things, and it appears that the exponential height fog is what's causing the strange shadows on it. If you know how I could fix this while keeping the exponential height fog, that'd be wonderful. Thanks! :) \$\endgroup\$ Aug 17 at 19:42
  • \$\begingroup\$ As I said, I still don't see the problem. \$\endgroup\$
    – Philipp
    Aug 17 at 20:20
  • \$\begingroup\$ @Philipp Oh, sorry, any black spots are what I mean. They're not there once I turn off the exponential height fog, and obviously you can't see it in the image but the shadows sort of move and glitch around. \$\endgroup\$ Aug 17 at 20:56

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.