-1
\$\begingroup\$

Upon opening a new project or template the unity launcher dies and shows the error message:

Could not find Unity Package Manager local server application at 
[/Applications/Unity/Hub/Editor/2020.3.15f1/Unity.app/Contents/Resources/PackageManager/Server/UnityPackageManager]. 
Missing files could be the result of an antivirus action or a corrupt Unity installation.

If I diagnose it says

❓ UPM health check (UNKNOWN)
Start the UPM process and call its health endpoint
>> Could not find UPM executable at path '/Applications/Unity/Hub/Editor/2020.3.15f1/Unity.app/Contents/Resources/PackageManager/Server/UnityPackageManager'

Anyone that cane help it would be greatly appreciated

\$\endgroup\$
1
  • 3
    \$\begingroup\$ The message says that there are missing/corrupt files in the Unity installation. Something/someone messed with the files. Have you tried to remove Unity and do clean install? \$\endgroup\$
    – Nikaas
    Jul 27 at 7:43
0
\$\begingroup\$

I had that problem yesterday, and I solved it by uninstalling Unity and reinstalling it.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.