0
\$\begingroup\$

On a few objects I use a technique where instead of using geometry, I place planes with a Cutout Material on top of each other, creating a 3D illusion with minimal cost. The thing is, it looks great with Unity's Realtime Lighting, but Baked Lighting darkens some of them.

The floor, walls and ceiling look close perfect, while the door's details are completely ruined. This was the reason I stopped baking light, but that is not a viable option as I am aiming to make it a Quest 2 Standalone project. Without baking, it just can't run it, with baking it is 100+ FPS on average.

I even turned off AO, just in case, but that didn't work either.

So my question is, that how can I fix this? Is there a stupidly simple solution, or is there a way to bake the "primitive" Realtime Lighting instead of the accurate Baked Lighting?

After countless hours of baking I'm out of ideas and started to lean towards making the problematic parts with actual geometry. That could be a bit heavy on the polygon side, but I could then include that too in the main 4K Texture Atlas. I'm quite unsure if that would be such a huge performance hit if any at all (since I could get rid of 3-4 Cutout Materials, making the SetPass calls even lower), but I'd like to keep the current approach if possible.

Realtime Lighting: Note how well the color of the door detail and the door itself match. Realtime Lighting

Baked Lighting: Now the door details are way too dark. Funnity enough the floor, walls and ceiling do actually look better baked. Baked Lighting

PS: I know the baked image is a lot darker anyway, which is not intended and will be fixed if I find a solution to this issue first. I know how to add more strength to lights. :P

\$\endgroup\$
3
  • \$\begingroup\$ Forget it. I decided to do the critical parts with polygons instead. I even got rid of some SetPass calls and Batches in the process. I won't put it as an answer tho, since the question might come handy for someone if it gets actually answered. I hope my Quest 2 won't mind the extra polygons tho. Fingers crossed. \$\endgroup\$
    – 505Legion
    Jul 13 at 4:55
  • \$\begingroup\$ Baked lighting won't look right if the mesh has overlapping UVs, because the shadows are baked by UV coordinates. \$\endgroup\$
    – Kevin
    Jul 13 at 19:40
  • \$\begingroup\$ After experimenting I realized that I didn't generate Lightmap UVs, which resolved many of my issues. As for the planes on top solution, I'm looking forward to try Parallax Mapping, as that seems like a more viable option to me. \$\endgroup\$
    – 505Legion
    Jul 14 at 15:26
0
\$\begingroup\$

I didn't generate Lightmap UVs. After I generated them and tweaked the settings, the overall lighting quality got a lot better.

\$\endgroup\$
1
  • \$\begingroup\$ This answer would be even better if it explained the steps for how you generated lightmap UVs, and what specific tweaks you made to the settings. \$\endgroup\$
    – DMGregory
    Jul 15 at 1:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.