I want to layer a grass texture with opacity over a dirt texture to form an edge. Both on the same model. But I'm getting edge bleeding from the opacity. I made both textures within Substance Designer (or any other texturing app). The 1x1 model is just a default plane made within Blender (or any other modelling app). You can see the bleeding in Substance Designer and in Unity. I did make a fast simple layered shader within Unity for both materials, just for reference. So I can apply both materials onto one mesh. I do think, that I understand why this is happening, but how do I fix it? Maybe there is a much better way to do this? I'm using URP.

Substance Designer (grass):

enter image description here

Within Unity:

enter image description here

I want to achieve something like this:

enter image description here

  • 1
    \$\begingroup\$ Can you show us your import settings for the opacity mask texture, so we can see how the wrap/repeat/clamp mode is set? \$\endgroup\$
    – DMGregory
    Jul 8, 2021 at 21:26
  • \$\begingroup\$ Wrap Mode: currently used Repeat (other options: Clamp/Mirror/Mirror Once) It seems that any other setting fixes it. Which one is the way to go? I'm currently using the basic Substance Designer import settings. \$\endgroup\$
    – julian.a
    Jul 8, 2021 at 21:53

1 Answer 1


Select the texture in your Assets folder, and change the Wrap Mode to Clamp.

This says that samples near the edge of the texture should clamp to the pixel on that edge, instead of repeat which wraps around to blend with the pixels from the opposite edge (good for when you want tiling effects, not so good for a single quat)


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .