0
\$\begingroup\$

I was trying to make a game for the Oculus Quest 1 with Unity and Oculus plugin.

Until yesterday, everything was working fine but now, when I click on "OVR build APK and run" (as I always did), after the build is finished, Unity is stuck on "Installing APK".

I tried:

  • restarting Unity, the Oculus and the Computer;
  • run everything as administrator;
  • soft-resetting the oculus;
  • using "Build and Run" instead of "OVR build APK and run"
  • using only "Build" and installing the app with Sidequest (but got stuck on "Checking APK against blacklist");
  • using two other computer (Windows 10);
  • using adb install -r app.apk (but got stuck on Performing streamed install...")
  • removing the app from the oculus before reinstalling.
  • trying to compile an older version of the project.
  • using another Oculus (Quest 2)

The logcat wasn't helpful.

Unity version: 2020.3.12f1 personal

Sidequest version: 0.10.21

Oculus XR plugin version: 1.9.1

OpenXR plugin version: 1.2.3

The oculus was last updated a few days ago, but it was working even after the update.

EDIT: tried with another computer (Windows 10, every software/plugin version matches mine) and unity gives another error: OVRADBTool Error type 3 Error: Activity class {com.Scuola.VR_Scuola/com.unity3d.player.UnityPlayerActivity} does not exist.. Nothing changes with Sidequest.

Tried also wit a macbook, every software/plugin version matches mine but it works perfectly with both Unity and Sidequest.

\$\endgroup\$

1 Answer 1

0
\$\begingroup\$

Solved by reinstalling all the XR related plugin and creating a new project.

\$\endgroup\$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .