0
\$\begingroup\$

I'm creating a simple Pachinko-style game and using a single button to drop balls in. Everything is working great, but the Unity Editor is throwing an ArgumentException for the Submit axis "not set up", so I added it to the InputManager only for it to then throw the same error for the Cancel axis.

When I first started the project I deleted the default axes from the InputManager and replaced them with a single one I've called "Fire". I don't use any other axes in any of my two script.

If I select the error in the console it jumps me to BaseInput.cs

I researched this for a while, but the only solution I saw was regarding a misspelling of the axis name, but I'd like to be clear that in this case the axes involved are totally unused in my code.

\$\endgroup\$
2
  • 1
    \$\begingroup\$ Do you have a Standalone Input Module in any of your scenes, supporting interaction with your UI canvas? \$\endgroup\$ – DMGregory Jun 3 at 5:26
  • \$\begingroup\$ Yes! I disabled that component on the EventSystem and it totally worked! Thanks so much! (Still trying to figure out how to mark your comment as the answer, though!) EDIT: I suppose I can't mark that as an answer, so I added an answer below. \$\endgroup\$ – VGpunx Jun 3 at 19:23
0
\$\begingroup\$

Thanks to DMGregory for answering this! The problem was indeed caused by a Standalone Input Module on my EventSystem which was created when I added the UI Canvas. Thanks so much!

\$\endgroup\$
1
  • \$\begingroup\$ Note that these inputs are needed if you want players to be able to navigate your UI using a keyboard or gamepad. This can be important for accessibility, so it's worth mapping these controls to inputs in your Input Manager. \$\endgroup\$ – DMGregory Jun 3 at 19:44

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.