I'm on a Mac, running Unity 2021.1.5f1 Personal, and am trying to remove an asset I downloaded using Package Manager.

So for the asset in question, I want Unity to have to download the package again, from the Asset Store, to my local mac. That option is currently unavailable, because I have downloaded it in the past.

I've tried deleting the contents of these folders, to remove the downloaded file, but still no "download" option shows up next to the asset.

  • ~/Library/Unity/Asset Store/Cache
  • ~/Library/Unity/cache
  • MY_PROJECT/Library/PackageCache
  • I also tried clearing the cache in Preferences | Gi Cache
  • I looked in the docs for Asset Store cache, and the closest I found was this link

1 Answer 1


On a Mac, this is where Unity was downloading all it's Asset Store packages:

~/Library/Unity/Asset Store-5.x/

I then searched for the name of the plugin, found it, and removed it's folder


# find bad plugin    
$ grep -r BadPlugin *

after doing this, the download option appeared again, and I could download the asset again from the asset server.


You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .