0
\$\begingroup\$

I have a 3D Humanoid model. When I press play button, suddenly position of model changes and collider doesn't match with model.

Before After

\$\endgroup\$
0
\$\begingroup\$

Not sure if this may solve it, but try changing Update mode to Normal if it doesn't solve it try to desactivate Animator tab. if the latest solves your problems, that means that you should probably play with options in your currently used animations properties. That's all i can think of :)

\$\endgroup\$
4
  • \$\begingroup\$ I tried your first solution and didn't work. But I couldn't understand second solution. How can I descative Animator tab and How is it gonna help about colliders ? Thanks for your help \$\endgroup\$ – Alpay Palabıyık Apr 28 at 4:43
  • \$\begingroup\$ I meant the Animator component. you see in the first image at the left of "Animator" uncheck it and observe if the problem still happens \$\endgroup\$ – TensaDev Apr 28 at 6:02
  • \$\begingroup\$ sometimes animations are well made and you need to check/uncheck some parameters so that the animation doesn't go out of your character position. To make it simple, you can think of them not centering the animation character when making them. \$\endgroup\$ – TensaDev Apr 28 at 7:18
  • \$\begingroup\$ Nothing happened. Thanks for comment \$\endgroup\$ – Alpay Palabıyık Apr 28 at 13:41

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.