0
\$\begingroup\$

How can I disable an Animator from the Animation in Unity?

The Animator enablement checkbox seems to be highlighted, which makes me believe that the enablement of the Animator is an animatable property itself. But whenever I try to animate it the enablement toggling just does not get recorded onto the animation line.

enter image description here

It feels like I am missing something here. If someone notices me doing something wrong, could you, please, point it out.

\$\endgroup\$
1
\$\begingroup\$

When you use the animation time-line, Unity will automatically disable the animator component, even if you aren't trying to modify it. Try implementing the animation and then seeing if it will work.

\$\endgroup\$
4
  • \$\begingroup\$ Do you maybe happen to know a place in documentation which would prove what you are saying? \$\endgroup\$
    – some1 here
    Mar 26 at 19:41
  • \$\begingroup\$ What does it even mean to implement an animation and see later if it works? I can clearly see that the Animator enablement property does not get added into an animation. \$\endgroup\$
    – some1 here
    Mar 26 at 19:44
  • \$\begingroup\$ Make it so when the character dies, it plays the animation and see if the animator component gets disabled when it plays in the game. \$\endgroup\$
    – Simonster
    Mar 26 at 20:46
  • \$\begingroup\$ It does not get disabled. \$\endgroup\$
    – some1 here
    Mar 27 at 8:36

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.