0
\$\begingroup\$

I've downloaded this asset and it looks perfectly fine in preview, and even in blender.

enter image description here

But when I import it in Unity, one of its shoulder is inside out, even after making all faces double sided.

enter image description here

I also tried switching the normal mode in the import settings to Calculate.

enter image description here

What causes this issue and how could I fix this?

\$\endgroup\$
2
  • \$\begingroup\$ Can you show us the shader/material you're using to render this? \$\endgroup\$ – DMGregory Mar 10 at 12:26
  • \$\begingroup\$ I'm using Unity's Standard material, everything is set to default, only the Albedo Map is set as the provided one. \$\endgroup\$ – Tudvari Mar 10 at 15:20
2
\$\begingroup\$

When you view the model in the Sketchfap viewer, click on the "Model Inspector" button and then enable "Vertex Normals", then you can see that the right shoulder of that character indeed has inward-facing normals. This is a mistake in the model, not with the way you import it. Such a mistake is easy to make, because many 3d modeling programs have two-sized rendering enabled by default (to improve usability), while most game engines do not (to improve performance).

You should be able to fix that in Blender by selecting the shoulder and flip the normals.

But if you really don't want to mess with the model and use it as it is, then another option is to use a shader which supports two-sided rendering. How to find/create such a shader depends on what render pipeline you are using.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.