1
\$\begingroup\$

I've made a selection of modular walls for a game i'm working on and some of the pieces have moving parts, like doors and flaps, but the moving pieces with an armature attached don't use vertex snapping like all of the other pieces and it leaves ugly gaps in the walls.

I've tried everything I can think of to get them lined up, the closest I can get is lining them up by eye and this leaves small gaps when in game and isn't perfect.

Does anyone know of a way to get vertex snapping to work with meshes that have an armature attatched?

I've attached a picture to try and explain:

enter image description here

\$\endgroup\$
1
\$\begingroup\$

Quickest solution I can think of is to disable the Skinned Mesh Renderer and add a Mesh Renderer and Mesh Filter to the wall. Add the mesh to the mesh filter. Now you can see the same mesh( in a static way) and vertex snap will work. After you have placed them you can delete the extra components.

\$\endgroup\$
1
  • \$\begingroup\$ Perfect thanks a lot mate! \$\endgroup\$ Feb 6 at 13:38

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.