0
\$\begingroup\$

I modify the Unity Platformer Minigame and want the main camera to display less of the lower part of the view. The Y coordinate in the inspector of the main camera is always -0.2777786 and I cannot change it.

enter image description here

I think what I want to is very simple so it should not take several hours of confusion.

\$\endgroup\$
3
  • \$\begingroup\$ I am not familiar with the project you have there (adding a link might help), but I would suspect that the Cinemachine camera system takes control of the camera through the CinemachineBrain component. \$\endgroup\$
    – Philipp
    Commented Feb 1, 2021 at 16:01
  • \$\begingroup\$ @Philipp Actually, that worked! Solved in 10 seconds \$\endgroup\$ Commented Feb 1, 2021 at 16:06
  • \$\begingroup\$ Then please post an own answer, so others can benefit from your solution. \$\endgroup\$
    – Philipp
    Commented Feb 1, 2021 at 16:06

1 Answer 1

2
\$\begingroup\$

After 11 hours of RT*M I found the correct answer on the Unity Forum:

"You won't be able to drag the camera in the scene view because it's locked with the object/sprite that it's following, BUT instead you can change the positions of the VM Cam inside the Inspector;'s cinemachine component:

Inspector > CinemachineVirtualCamera > Body > Screen X (or Screen Y)

Adjust the X and Y settings there and it will move the position of the camera. "

It worked.

\$\endgroup\$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .