0
\$\begingroup\$

I just opened a project made in unity version 2018.1.1f into Unity version 2020.1.1f I know opening the older projects is not supported by Unity but it opened fine.

The only problem is that it is giving an error which looks like this-enter image description here

What I tried:

  1. checking the script onetizationPlatform.cs to ensure nothing is wrong in it
  2. checked that there's no two files with same name unitylifecyclemanager
  3. doing point 2 with unityengine.advertisement.editor
  4. deleting unityengine.advertisement.editor which caused another error so I had to restore it back
\$\endgroup\$
9
  • 2
    \$\begingroup\$ While I haven't experienced this particular error myself, I have resolved similar errors after updates by checking the package manager and making sure all packages are up-to-date. \$\endgroup\$
    – Philipp
    Jan 3 at 5:36
  • \$\begingroup\$ Is it possible UnityEngine.Advertisements.Editor used to be a standalone package and is now part of UnityEngine.Advertisements? (which would then conflict with the one still in your project). Since the latter has a higher version than the more specific one..? \$\endgroup\$
    – D.Kallan
    Jan 4 at 15:30
  • \$\begingroup\$ I've had this problem before with some other package, and it was caused because I had installed package X manually, but it was also a dependency of some other package. So I had two versions of the same package. I solved it by removing the manually installed package and using the one that was the dependency. \$\endgroup\$
    – Eldemarkki
    Jan 4 at 15:49
  • \$\begingroup\$ Sorry but I didn't installed any package manually and also made sure that all of my packages are up to date \$\endgroup\$ Jan 4 at 16:01
  • 1
    \$\begingroup\$ @D.Kallan Thanks mate! The problem is quite similar to mine,and maybe doing this will fix it. I'll update you about whatever happens \$\endgroup\$ Jan 5 at 13:36
1
\$\begingroup\$

I fixed the problem by first removing unity advertisements from package manager and then deleting every single advertisement or monetization related file from my project

After that I reinstalled unity advertisement from package manager which first gave 2-3 errors which were clearable and then everything started working nicely.

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.