0
\$\begingroup\$

How to pause the lighting bake and quit the project ? so when i re-open the scene it will continue baking without have to start the bake from beginning ?

I need to take a break to do other job on my computer, because after i turn on 'auto generate' , the baking takes very very long. I want to quit unity and continue later.

Right now if i reopen the project , it will bake from start again.

Thanks

\$\endgroup\$
5
  • \$\begingroup\$ Baking can't be interrupted and restarted. \$\endgroup\$
    – Almo
    Dec 2 '20 at 20:03
  • \$\begingroup\$ that's crazy, i have to wait for ETA 500 hours after leaving it for whole night. :-) ... for just a low poly house and simple low poly furnitures. \$\endgroup\$
    – andio
    Dec 3 '20 at 2:47
  • \$\begingroup\$ I suspect you have other problems \$\endgroup\$
    – Almo
    Dec 3 '20 at 4:20
  • \$\begingroup\$ @andio What hardware are you using? If you are on an ancient or extremely low-end CPU, your computer may just not be suitable for baking lighting. If you have a decent CPU, you may have set up your lighting settings incorrectly. \$\endgroup\$
    – Kevin
    Dec 3 '20 at 19:46
  • \$\begingroup\$ @Kevin macbook pro 16, intel i9 - 2.3hz 8 core, radeon 5500M 4GB vram, 16GB RAM. Not a powerful one for 3d, but also not prehistoric laptop :-) . I don't know what is wrong, is this mac version doesn't work well ? or the radeon ? i can't figure it out. \$\endgroup\$
    – andio
    Dec 4 '20 at 2:17
1
\$\begingroup\$

Since your hardware should be up to the task of baking, it's time to troubleshoot other possible issues. I can't comment on whether there's an issue with baking in Mac versions of Unity.

Some simple things to try:

  1. Upgrade to the latest version of Unity if you haven't already, in case this is a bug they've already fixed.
  2. Try creating a new scene in a new project, add a couple of cubes, and bake. If it goes fast, this suggests there's something wrong with the settings or assets in the scene you're trying to bake in your main project.
  3. Try switching the lightmapper between "Progressive CPU" and "Progressive GPU" to see if that resolves the issue
\$\endgroup\$
1
  • \$\begingroup\$ Thanks, i 'll try that and see how it goes. \$\endgroup\$
    – andio
    Dec 4 '20 at 2:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.