1
\$\begingroup\$

I've been running Unity 2020.1 on Ubuntu 19.04 without any problems for a while now. Today, I installed the VSCode extension asset and now Unity just crashes during startup. I choose my project from Unity Hub, the splash screen and progress bar pops up, and then everything just shuts down.

I've already submitted a crash report but I'd rather just revert the extension entirely so I can get working again. I've tried deleting the files from disk but Unity just downloads them again during startup.

How can I either remove or disable the VSCode extension completely without starting Unity?

\$\endgroup\$
0
\$\begingroup\$

Back up your project. Don’t open unity until the end of these steps.

Then, You can delete the library folder. Then, in the packages folder, open manifest.json and delete the entry for the vscode add on. Careful you don’t make a syntax mistake. Then do the same in package-lock.json in the same folder. Then make sure unity is up to date. And reopen.

This solution assumes you are using a relatively new unity version >= 2019

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.