0
\$\begingroup\$

My problem can be seen here notice how the shadows don't change intensity or color when moving indoors to the cave. The only thing that changes is the highlights when I move under the directional light. I was thinking about adding global illumination but I don't think that would work with a toon shader. How can I get my lighting to become darker once I enter indoors e.g a cave. Thanks!

\$\endgroup\$
1
\$\begingroup\$

One solution is to setup light probes so your dynamic objects receive bounced light information from the static environment.

As explained in the manual: Light Probes for moving objects.

\$\endgroup\$
3
  • \$\begingroup\$ Is this possible for a toon shader though? \$\endgroup\$
    – Bobby B
    Aug 4 '20 at 15:09
  • \$\begingroup\$ According to your video, your character receives lighting information. so yes as long as it is not an Unlit shaded material. this should work. \$\endgroup\$ Aug 5 '20 at 9:02
  • \$\begingroup\$ Ya I thought so as well but no matter which shader I try that says it supports GI, it just doesn't seem to work. The lighting gets a bit more realistic e.g in the world but my model stays the same. Light probes don't seem to work even when I enable them. \$\endgroup\$
    – Bobby B
    Aug 5 '20 at 13:25

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .