0
\$\begingroup\$

I am having a weird transparency issue when running my game in windowed mode. Parts of the window, left and top parts in normal window mode, right and bottom when in maximised window, become transparent. It is full transparency not just an uncleared buffer as I can see movement from other windows behind. The size of the area that is transparent varies slightly between runs. I'm pretty sure it worked in January when I last worked on the game.

Window with parts of rendering area transparent

If I resize or iconify/restore the window either manually or programmatically with GLFW it fixes itself and renders the full window as expected.

glfwGetFramebufferSize, glfwGetWindowSize and glGetIntegerv(GL11.GL_VIEWPORT) all report the same correct values before and after a resize. Calling glViewport does not fix the issue. I am not getting any relevant openGL errors.

If I start the game window maximised on the displays connected to the old graphics card R9 290X I do not get this problem but window maximised on newer RX 5700 XT display still has the problem but in bottom right instead of top left. Full screen works fine on all displays.

Have not seen any problems with other games I have but I always run them in fullscreen and they are mostly DirectX or Vulcan.

Has anyone encountered this problem before? I would rather not have to programmatically modify the window size by 1 pixel each start as that is an ugly fix.

If anyone wants to test on their system to see if it is a code or driver error run either the full packaged jar (in sandbox preferably) or checkout minimal error example yourself and execute "./gradlew run".

  • Windows 7
  • GDX 1.9.11 (also tried 1.9.10)
  • LWJGL 3.2.3 (also tried 3.2.2)
  • Java AdoptOpenJDK 12.0.2
  • AMD driver 20.7.2
\$\endgroup\$
  • 1
    \$\begingroup\$ This appears to be a lot of (guess)work to browse through your code. Could you provide an MCVE, and post the code inside the question instead of relying to an external source? \$\endgroup\$ – Vaillancourt Jul 31 at 18:14
  • \$\begingroup\$ I am afraid i have not managed to narrow it down to any specific part of the code. From window creation and first frame rendering of the mostly black loading screen the problem is already there. \$\endgroup\$ – exuvo Jul 31 at 18:42
  • 1
    \$\begingroup\$ Did you consider testing it on a more recent system? Windows 7 is... old and mostly dead. \$\endgroup\$ – Vaillancourt Jul 31 at 18:49
  • \$\begingroup\$ My main PC is win7 and i'm not updating to win10. Planning an upgrade to linux but have not had time yet. My old laptop has broken opengl drivers so cant run anything at all there. I have asked a few friends to run it (win7 and win10) but response will come earliest tomorrow and still wont help me figure out why it does not work on my computer. I updated the repository link to a MCVE branch. \$\endgroup\$ – exuvo Jul 31 at 19:00
0
\$\begingroup\$

AMD driver issue, managed to reproduce it in another previously working (last month) opengl game. Have filed a bug report with AMD.

| improve this answer | |
\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.