1
\$\begingroup\$

I have uploaded a model to mixamo.com. In mixamo, I've applied an animation, and in the mixamo preview window, the feet are perfectly stable, they don't skate at all.

I have downloaded the resulting fbx animation together with the skin, and I have opened it up in Autodesk FBX review.

In Autodesk FBX review, the feet are also perfectly stable.

I have then imported the fbx in Unity without changing anything.

In the animation preview window, the feet are skating.

Why is that so, and how do I get rid of it?

\$\endgroup\$
3
  • \$\begingroup\$ Please provide screenshots of your model import settings, that way we will have more information to work with. 👍 \$\endgroup\$
    – eLTomis
    Jul 23 '20 at 9:53
  • \$\begingroup\$ @eLTomis I have not applied / changed anything, I just imported it into Unity. Should I provide them anyways? \$\endgroup\$
    – tmighty
    Jul 23 '20 at 9:54
  • \$\begingroup\$ oh, if nothing is changed, then no - not neccessary. Just edit your question and mention that you kept default import settings. 😉 \$\endgroup\$
    – eLTomis
    Jul 23 '20 at 9:56
1
\$\begingroup\$

I found out that the skating feet were caused by the option "Anim. Compression: Keyframe Reduction" in the Unity Animation tab.

Once I set Anim. Compression to "Off", the skating feet were gone.

enter image description here

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.