1
\$\begingroup\$

I used Unity 2019.4 on Ubuntu 20.04. I installed Android SDK and all other components through Unity Hub. But unfortunately, I can't use Unity remote. It's written : Set up Android SDK path to make Android remote work. I need help. Thanks enter image description here

\$\endgroup\$
  • \$\begingroup\$ Try making android build. It should throw errors as well. If it does, this might be linked to it. I saw solution somewhere, will post as an answer later. \$\endgroup\$ – eLTomis Jul 19 at 12:26
  • \$\begingroup\$ I successfully make android builds but the issue is still there \$\endgroup\$ – Achie1 Jul 19 at 12:51
2
\$\begingroup\$

It might be related to Unity issue found since 2019.3. See this issue on Unity issue tracker. It shows how to resolve issues regarding OpenJDK, Android SDK and NDK.

Solutions, provided in the link

In case the link becomes inaccessible, here's a qoute from the link.

  1. The executables in OpenJDK (Editor/Data/PlaybackEngines/AndroidPlayer/OpenJDK) don't have the right permissions for execution (possibly due to wrong compression/uncompression of JDK archive) - "chmod +x OpenJDK" fixes the JDK location.
  2. Android SDK (Editor/Data/PlaybackEngines/AndroidPlayer/SDK) is missing the tools directory in it. Copying the tools dir from somewhere else fixes SDK.
  3. Android NDK is unpacked to the wrong directory (Editor/Data/PlaybackEngines/AndroidPlayer/NDK/android-ndk-r19 instead of Editor/Data/PlaybackEngines/AndroidPlayer/NDK, compared to other platforms) - moving the contents to the correct directory fixes NDK.
| improve this answer | |
\$\endgroup\$
2
\$\begingroup\$

I was having the same issues on Windows, with the latest Unity 2019.4 installed from Unity Hub 2.3.2. Just figured out how to get remote working. My solution was to install and run Android Studio(unlike for Unity 2018, having to just download SDK) to configure the SDK. After installing and finishing the setup wizard, there is a "Configure" button on the bottom of the Welcome screen, click to navigate to "SDK Manager". The SDK Manager should open up to the "SDK Platforms" tab in the "Android SDK" option under "System Settings" on the left hand side. Here, you should make sure the Android version you will be running the remote on is checked. Then, in the tab next to the platforms one labeled "SDK Tools" make sure "Google USB Driver" is also checked. Apply the changes with the button at the bottom and wait for the changes to be downloaded and installed. Now, in SDK Manager still, you can copy the location of the newly optimized SDK into your Unity project preferences. Before I tested the remote, I made sure on my phone USB debugging was enabled and that when connecting my phone to the computer: the USB Option on my it was set to "Charging Only" (I had changed it to Media Sync some time ago and forgot), this allowed my phone to recognize my computer's RSA fingerprint when connecting with a cable. After that, I played a test scene, and got it working like before. Sorry if what I typed was too long, but would like to know how it turns out for you.

| improve this answer | |
\$\endgroup\$
0
\$\begingroup\$

The bug has been fixed now in Unity 2019.4.8. For Samsung devices users who still face the problem, when you connect the cable, go to notifications panel, don't use TRANSFER FILES option, use TRANSFER IMAGES. In Unity Remote 5, follow instructions on the screen and everything will work fine.

| improve this answer | |
\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.