0
\$\begingroup\$

I am new to unity and i am trying to make a AR app. I have installed AR foundation, Arcore Xr plugin, Arkit XR plugin via package manager. Then if i go to the Hierarchy panel to add a AR session and right click, I am not seeing any XR option to add a AR session. What should i do now? Anyone please help me.

Package manager

\$\endgroup\$
3
  • \$\begingroup\$ The usual troubleshooting advice here is to check whether removing your plugins, restarting Unity, reinstalling helps. Sometimes deleting your project's Library folder can also help force Unity to refresh an asset that's been corrupted somehow and is misbehaving. If the problem persists, see if you can reproduce it in a new, empty project. If so, update your question with the complete list of steps we need to take to reproduce the issue, so we can spot a potential missing step and test potential solutions. \$\endgroup\$ – DMGregory Jul 12 '20 at 11:39
  • \$\begingroup\$ I tried restarting, reinstalling, deleting the project files but nothing has worked - @DMGregory \$\endgroup\$ – Th_official Jul 12 '20 at 13:17
  • 1
    \$\begingroup\$ What Unity version are you using? What Unity modules do you have installed (i.e. Android/iOS build support)? \$\endgroup\$ – MichaelHouse Jul 12 '20 at 16:45
0
\$\begingroup\$

Check your Unity install configuration, I see the option with this configuration:

  • Unity 2019.4.3f1 (LTS)
  • The Android and iOS modules installed (at Unity install time, or later via Unity Hub's "Add Modules")
  • AR Foundation, ARCore XR plugin, ARKit XR plugin via package manager

The following options appears when right clicking inside the Hierarchy panel:

enter image description here

When adding an "AR Session", you'll find it under the "XR" menu option. This is a very similar menu that appears when selecting "GameObject->XR" from Unity's top menu bar.

\$\endgroup\$
1
  • \$\begingroup\$ It sounds to me like OP is saying the XR option does not appear in their context menu. Any idea what they might need to do differently to make it appear? \$\endgroup\$ – DMGregory Jul 12 '20 at 16:30

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.