0
\$\begingroup\$

Whenever I drag a sprite sheet into unity, it, for whatever reason, distorts. Is there any way to remedy this?

Original

enter image description here

Distorted

enter image description here

\$\endgroup\$
  • \$\begingroup\$ I'm seeing some telltale BC5-like block compression artifacts here. What compression do you have selected in the import settings? \$\endgroup\$ – DMGregory Jul 11 at 6:55
1
\$\begingroup\$

Click on your texture, the texture import settings appear in the inspector window.... look for Filter Mode... bilinear, trilinear, point. Try changing it to Point(no filter) and that should eliminate any distortion. And what do you exactly mean by distortion? It seemed fine for me when I imported with point filter mode. Anyway let me know if it worked.

| improve this answer | |
\$\endgroup\$
  • \$\begingroup\$ Yeah, I had it set to bilinear. What I did is that I just dragged the file in from my pc. \$\endgroup\$ – Stormzy18 Jul 11 at 17:56
1
\$\begingroup\$

Click on the image asset in your "Project" tab and check its import settings in the "Inspector" tab. For pixel art you usually want the following settings:

  • Texture Type: Sprite (2D and UI)
  • Filter Mode: Point
  • Compression: None
| improve this answer | |
\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.