0
\$\begingroup\$

I just added URP to my project then upgraded the materials to URP and now it's not rendering the environment anymore

Screenshot of scene and game view

Camera settings in inspector

I found the problem is that I have 2 cameras which are stacking on each other: one with a priority of 1 and the other 0 . The camera that has higher priority is blocking the lower priority camera.

How can I fix that? I want to render the higher priority camera on top of the lower priority one.

\$\endgroup\$
7
  • \$\begingroup\$ What should your environment look like instead? Can you show us how its material is configured? \$\endgroup\$ – DMGregory Jul 2 '20 at 15:10
  • \$\begingroup\$ @DMGregory well it should look like the Scene view and the material is simple here is image imgur.com/a/vp5OvJk \$\endgroup\$ – Armin Malek Jul 2 '20 at 15:22
  • \$\begingroup\$ Great. Next, can you edit your question to show the configuration of your camera, your rendering settings, and your render pipeline asset? \$\endgroup\$ – DMGregory Jul 2 '20 at 15:24
  • \$\begingroup\$ @DMGregory I found the problem can you help me with that? \$\endgroup\$ – Armin Malek Jul 2 '20 at 17:39
  • \$\begingroup\$ Sounds like you should edit your question to include how you've configured both cameras. Is it safe to assume you've configured your stack as documented here? \$\endgroup\$ – DMGregory Jul 2 '20 at 17:42
0
\$\begingroup\$

I was overlaying cameras on each other in the SRP so, in order to make it work in URP, I just had to Stack them properly link to documentation

\$\endgroup\$
1
  • \$\begingroup\$ This answer would be even better with a description of the steps you had to take to implement this. \$\endgroup\$ – DMGregory Aug 1 '20 at 23:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.