0
\$\begingroup\$

I'm new to UE4 (4.24 on Ubuntu 16.04) and I'm using AirSim and the Blocks world.

Whenever I create a C++ class, I get the following message:

enter image description here

"Successfully added class 'MyActor', however you must recompile the 'Blocks' module before it will appear in the Content Browser. Failed to automatically compile the 'Blocks' module".

And here is my Message log:

WARNING: Library 'stdc++' was not resolvable to a file when used in Module 'AirSim', assuming it is a filename and will search library paths for it. This is slow and dependency checking will not work for it. Please update reference to be fully qualified alternatively use Public System Library Paths if you do intended to use this slow path to suppress this warning.

ERROR:'/home/user/AirSim/Unreal/Environments/Blocks/Intermediate/Build/Linux/B4D820EA/UE4Editor/Inc/Blocks/MyActor.generated.h': Changes to generated code are not allowed - conflicts written to '/home/user/AirSim/Unreal/Environments/Blocks/Intermediate/Build/Linux/B4D820EA/UE4Editor/Inc/Blocks/MyActor.generated.h.conflict'.

The .h and .cpp are created in a Source folder within Bocks and AirSim, but nothing appears in the "Content" folder where initially I right clicked it to add a C++ Class. I've tried closing UE4 but I've no idea how to open the Source folder on UE4, and the files do not appear in the Content folder. I've already searched for this error message, I've found some things, but they couldn't solve my issue. Can anyone help? TIA

\$\endgroup\$
  • 1
    \$\begingroup\$ Oh man, I know what this is - with some classes, there are a couple of methods you need to override before you can hot reload it. I can't remember what they are though, take a look at the virtual functions for your parent class. You're gonna have to open your platformer .sln with visual studio or an equivalent \$\endgroup\$ – Natalo77 Jun 10 at 14:58
  • \$\begingroup\$ Yes, I created a new project and had to do some stuff all over again! It is working now. It now compiles with no error messages and immediately shows up on C++ Classes on my editor. Thank you very much for the patience and for helping me!! :) \$\endgroup\$ – nmpm Jun 16 at 14:40
  • \$\begingroup\$ @nmpm please consider posting your solution as an answer. I'll migrate the rest of this discussion to chat. \$\endgroup\$ – DMGregory Jun 16 at 14:44
1
\$\begingroup\$

Had to create a project from scratch and migrate what I had. I tried to create a new C++ class and it worked

| improve this answer | |
\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.