0
\$\begingroup\$

i just updated my project from unity5 to unity 2018. my project uses ngui as UI solution. eveything works fine in updated version but when i want to edit prefabs in prefab mode i get this message:

enter image description here

is there any idea about cause of this problem and how to solve it?

i looked for updating ngui for unity 2018 but because of many changes ngui has, it causes lots of problem in project that takes lots of time to solve the mall

\$\endgroup\$
1
\$\begingroup\$

In 2018.4 you can edit prefab edit environment in ProjectSettings/Editor

| improve this answer | |
\$\endgroup\$
  • \$\begingroup\$ It's unclear how one would solve the error message in the question using this information. Can you edit your answer to explain in more depth? \$\endgroup\$ – DMGregory Jun 11 at 11:30
1
\$\begingroup\$

some special prefabs or gameobjects need a certain parent object. for example any Unity UI object needs to be parented directly or indirectly with canvas object. NGUI is the same and any ui object needs to be parented with object with UIRoot Component with same layer.

in new version of ngui its handled but in older versions Unity doesnt know what is the parent gameobject and in start of prefab editor you see the error and you have to return.

you can make an empty scene and drop a UIRoot in it and save it and in

Edit>Project Settings>Editor> Prefab Editing Environment

set that scene to Regular Environment and UI Environment

| improve this answer | |
\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.