1
\$\begingroup\$

I'm running MacOS 10.14.6. When I launch Unreal v4.25.0, I get the following warning:

xcode warning message

Xcode was not detected on this Mac.

Metal shader compilation will fall back to runtime compiled text shaders, which are slower. Please install latest version of Xcode for best performance, and make sure it's set as default using xcode-select tool.

When I try to install XCode, I'm told I need to upgrade to MacOS 10.15. I can't do this due to other software dependencies.

Is there a way to compile Metal shaders from the previous version of XCode somehow? If I can't install Metal, does it matter?

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.