0
\$\begingroup\$

Whenever i try to either create or open a Unity project, I get faced with this error.

https://i.stack.imgur.com/3CJju.png

Does Unity need a proxy server, because I dont have one. (If so, how do I get one?) And apparently I need to add some environment variables, (HTTP_PROXY, HTTPS_PROXY and UNITY_NOPROXY=localhost,127.0.0.1) what values do i add to these?

Unity Package Manager Diagnostics (v0.1.5)

Ran 7 checks

1 succeeded

6 failed

❌ UPM registry reachable (FAIL) Make an HTTP request to the UPM package registry

Connection error. This could be because a proxy is misconfigured.

❌ Ping UPM registry (FAIL) Measure the latency of the UPM package registry API

No successful pings could be made in 0.062 seconds (30 failed)

❌ Ping UPM download (FAIL) Measure the latency of the UPM package download endpoint

No successful pings could be made in 0.039 seconds (30 failed)

❌ UPM registry download speed (FAIL) Test the Internet connection using the UPM package registry

Connection error. This could be because a proxy is misconfigured.

❌ Speedtest.net (FAIL) Test the Internet connection using Speedtest.net

Connection error. This could be because a proxy is misconfigured.

✅ HTTP proxy environment variables (PASS) Detect whether proxy-related environment variables are set (HTTP_PROXY, HTTPS_PROXY, ALL_PROXY, NO_PROXY, UNITY_PROXYSERVER, UNITY_NOPROXY)

Proxy support has been configured through the following environment variables: HTTPS_PROXY = C:\Program Files\Unity Hub\Unity Hub.exe HTTP_PROXY = C:\Program Files\Unity Hub\Unity Hub.exe UNITY_NOPROXY = C:\Program Files\Unity Hub\Unity Hub.exe

❌ UPM health check (FAIL) Start the UPM process and call its health endpoint

Server started but did not respond to health requests: Error: Invalid protocol: c:

How do I fix this?

\$\endgroup\$
5
  • \$\begingroup\$ What Unity version are you using? Have you tried the solutions listed here? \$\endgroup\$
    – DMGregory
    Jun 5, 2020 at 21:31
  • \$\begingroup\$ I've tried setting up environment variables for both the package manager exe and the unity hub exe, but it didn't work. I also don't know how exactly to allow certain domains through the whitelist, and google didn't help. I also don't exactly know if unity does need a proxy server or not, and looking up how to get one didn't help. I just ran the Speedtest.net test, and my pings per second are 19 pings, and my download mps was 3.32, and upload mps was 6.99 mps. Nothing worked. \$\endgroup\$
    – Matatatutu
    Jun 5, 2020 at 23:59
  • \$\begingroup\$ This is trying to access a process on your own PC, so ping is not relevant here. You have some rule on your computer blocking communication between processes over http. \$\endgroup\$
    – DMGregory
    Jun 6, 2020 at 0:01
  • \$\begingroup\$ I have finally found the source of my problem. By turning off the firewall, i can access unity again, which means that the problem was about something being blocked in the firewall. Now I can properly fix the problem. Thank you for your help! \$\endgroup\$
    – Matatatutu
    Jun 6, 2020 at 1:19
  • \$\begingroup\$ If you've solved your firewall problem, I recommend posting the steps you took to solve it as an Answer below, to help other users with this issue. \$\endgroup\$
    – DMGregory
    Jun 6, 2020 at 1:23

1 Answer 1

1
\$\begingroup\$

I got the same error, checked 127.0.0.1 on my browser and got an error hence setx UNITY_NOPROXY localhost did not work for me, so I went to my windows defender firewall with advanced security, and turned off the domain ,public and private profiles since I already have Quick Heal on, and my project started working, I suppose there was a conflict between Quick Heal and Windows Defender as both of them were turned on! I hope that helps!

\$\endgroup\$
1
  • \$\begingroup\$ You can also tweak the rules for Unity alone, rather than opening up your firewall completely. \$\endgroup\$
    – DMGregory
    Jul 30, 2020 at 12:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .