1
\$\begingroup\$

I'm trying to create a 3D Sword Slash VFX and created the model for the effect in blender. It's basically a wedge or ufo-shaped mesh. I proceeded to paint a simple test texture to see how it would look in Unreal. Now, the UVs are setup correctly for the effect itself (bottom of the texture is outside of the ring and top of the texture is inside of the ring), but it seems like my texture is spilling.

I got clearly visible artifacts and I don't really know why. The artificats go away when I start erasing parts of texture at the bottom, but it also leads to the outside edge of the wedge model to get a gap. What can I do to prevent my texture from spilling over?

enter image description here

enter image description here


*Edit: Making the material I used Unlit helped, but it did not get rid off the problem completely. Using clamp is not an option for me, because I want to animate the texture with a UV-Offset to make it rotate. In the material editor preview there are no artifacts, but in the material instance preview window they appear again.

I created the mesh in this way: add a circle, extrude the edges up and then scale the vertices down. Then do the same but at the bottom. In the UV-Editor I dragged the UVs from the outside edge to the bottom and the vertices from the top circle and bottom circle to the top of the UV map.

enter image description here

enter image description here

\$\endgroup\$
1
\$\begingroup\$

Double-click your texture and change the X & Y Tiling Methods to Clamp instead of the default Wrap.

Image of texture properties

Image from the Unreal docs on Texture Properties

| improve this answer | |
\$\endgroup\$
  • \$\begingroup\$ Wrap is not an option for me, because I want to animate the texture in the material via UV-Offset. I have updated my original post. \$\endgroup\$ – iQew Jun 5 at 14:49
  • \$\begingroup\$ Good thing I never said to use Wrap then. ;) Clamp works just fine with UV offsets for rotation. \$\endgroup\$ – DMGregory Jun 5 at 14:58
  • \$\begingroup\$ Well, I meant it the other way around of course. I followed a tutorial and he said clamp won't work since it will cut off the texture when rotating the UVs. I've changed it to clamp now and it works indeed. Unfortunately, the artifacts still remain :( \$\endgroup\$ – iQew Jun 5 at 15:16
  • \$\begingroup\$ You set it to clamp on both X and Y? \$\endgroup\$ – DMGregory Jun 6 at 18:23
  • \$\begingroup\$ yes, I've set both to Clamp. I just launched the editor today and the artifacts are gone. I'm not sure how much I can trust this, because they were gone every now and then when I saved my material, but always came back at some point. Side question: why can't I tag anyone anymore? The tag is just missing when I post the comment and there's no dropdown when I'm writing the name. \$\endgroup\$ – iQew Jun 8 at 8:36
0
\$\begingroup\$

Turns out it was my own dumbness. There were very small amounts of "dirt" in my texture for some reason. They didn't show up in my preview screen, because they were really small and had transparency on them. Cleaning everything up solved the issue. Duh!

| improve this answer | |
\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.