0
\$\begingroup\$

I have a material which I have assigned to be used on a sphere game object which acts as stars.

This is what the settings are set to: Settings

And this is what the Game View looks like: Game view

I have also tried setting emission intensity to 0 nits and exposure weight to the minimum (0), but some stars still are far too bright, below is a screenshot of what it looks like with the altered emission intensity and exposure weight:

Settings with altered

The bigger stars are far too emissive. I am trying to give each star a little glow. How do I reduce the emission?

\$\endgroup\$
3
  • \$\begingroup\$ Presumably you tried modifying the "emission intensity" or "exposure weight" fields? \$\endgroup\$
    – DMGregory
    Jun 3 '20 at 13:45
  • \$\begingroup\$ I've tried that and it didn't achieve my goal, I've edited the question to show this. \$\endgroup\$
    – SidS
    Jun 3 '20 at 13:55
  • \$\begingroup\$ You might need to adjust your camera exposure then. It might be automatically increasing its exposure to balance the overall brightness whenever you darken your stars. This may be under the heading of "adaptation" \$\endgroup\$
    – DMGregory
    Jun 3 '20 at 13:59
1
\$\begingroup\$

Thanks to the helpful input from @DMGregory, I have managed to solve this problem.

I added the "Volume" component to the Camera, then I created a new profile. I then added the "Exposure" override, which resulted in the appearance of two shaded out options, Mode and Fixed Exposure. Clicking on the checkbox to the left activated the options allowing me to set the Mode to "Fixed" and Fixed Exposure to "0".

Changing the Fixed Exposure value any lower results in the stars becoming too bright, and any higher results in the stars becoming too dim. "0" seems to be the sweet spot for my application.

New settings

This is the result: End result - Game view

\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.