1
\$\begingroup\$

A few hours ago, Unity crashed on me. When I went to re-launch it from Unity Hub, that's when the nightmare started.

Any time I try to launch a project from the Unity Hub, the Unity Hub disappears, the Unity splash screen opens, and then about 3 seconds later the Unity Hub reappears, followed shortly by the Unity splash screen disappearing. I can't get the editor to actually load!

I looked in the Unity Editor log and found this:

[LicensingClient] ERROR Failed to connect to local IPC
[Licensing::Module] Failed to connect to channel: LicenseClient-Mason
[Licensing::Module] Successfully launched the LicensingClient
[Licensing::Module] Successfully connected to LicensingClient on channel: LicenseClient-Mason
[Licensing::Module] Successfully launched and connected to LicensingClient
Entitlement-based licensing initiated
[LicensingClient] Licenses Updated successfully in LicensingClient

LICENSE SYSTEM [202059 16:58:48] Next license update check is after 2020-05-10T19:18:29

Built from '2019.3/staging' branch; Version is '2019.3.10f1 (5968d7f82152) revision 5859543'; Using compiler version '191627012'
OS: 'Windows 10  (10.0.0) 64bit' Language: 'en' Physical Memory: 16332 MB
[Licensing::Module] License is not active (com.unity.editor.ui). HasEntitlements will fail.
BatchMode: 0, IsHumanControllingUs: 1, StartBugReporterOnCrash: 1, Is64bit: 1, IsPro: 0
No valid Unity Editor license found. Please activate your license.

I do, in fact, have a valid Unity Editor license. It was working just fine this morning, and it doesn't expire for several months yet. Looking at the "Manage license" function in Unity Hub confirms this. A bit of Googling suggests doing some of the following things, all of which I have tried, to no avail:

  • Reboot the computer.
  • Delete the Unity license file in C:\ProgramData\Unity and recreate it in Unity Hub.
  • Uninstall and reinstall Unity.
  • Update to the latest Unity version.

There was no Windows Update, driver update, or hardware change that could have provoked this. It happens no matter which version of Unity I attempt to open, and no matter which project I attempt to open, and nothing I do to attempt to fix it actually works!

The one thing that does work, for whatever reason, is creating a new Unity project. This creates a new project as expected, but the Unity theme is reverted to a light gray background, rather than the dark mode I'm accustomed to with my license, and once that project is closed, attempting to reopen it is just the same as attempting to open any other Unity project.

I tried opening Unity on my old, broken computer that has the same license, and it opens just fine... but that computer is old and broken, and will take several times longer to do anything on. Apparently there's some serious issue, specific to my dev machine, that came out of nowhere this morning and is causing license verification to fail.

Anyone have any idea how I can fix this or, failing that, how I can reach someone at Unity Technologies to get their help fixing it? Try as I may I can't find any option anywhere on their web site to reach a human being for customer service, at a time when I urgently need a live human being, rather than a "open a ticket and we'll try to respond to it within 3 days if you're lucky". I'm just finishing up something that I was hoping to have ready today, and this has disrupted everything!

\$\endgroup\$
1
\$\begingroup\$

Hit the same thing this week. Apparently newer versions of Unity Hub are just completely broken. There is a link to version 2.0.4 in this thread. Just downloaded it myself and verified everything works now. I would just avoid upgrading and follow that thread as well as the Unity Hub Release Notes.

\$\endgroup\$
1
  • \$\begingroup\$ Yeah, scroll down far enough and you'll see I eventually ran across that same thread. Unfortunately there doesn't seem to be any better solution than this. \$\endgroup\$ May 18 '20 at 0:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .