1
\$\begingroup\$

How can I manually set that Unity can read .blend file inside Unity?

I have portable Blender.

When I add blend file in Unity it says: Blender is not found. How to make Unity understand .blend file?

\$\endgroup\$

3 Answers 3

2
\$\begingroup\$

According to documentation, Unity imports .blend files through FBX. You're going to export your scene to FBX if you want to use your assets in your Unity project.

\$\endgroup\$
6
  • \$\begingroup\$ I understand that. But when I add blend file in Unity it says: Blender is not found. How to make Unity undestand .blend file? \$\endgroup\$
    – eon
    May 2, 2020 at 10:19
  • 1
    \$\begingroup\$ Did you see that one: forum.unity.com/threads/blender-could-not-be-found.55712 ? \$\endgroup\$
    – lvictorino
    May 2, 2020 at 10:25
  • \$\begingroup\$ Where is option in Unity to set Blender as default? \$\endgroup\$
    – eon
    May 2, 2020 at 20:51
  • \$\begingroup\$ As I understand it, it's from the OS. Does your OS know that Blender is the software to execute for .blend files? \$\endgroup\$
    – lvictorino
    May 2, 2020 at 20:53
  • 1
    \$\begingroup\$ If you're on Windows, right click on .blend file > open with > select Blender > check do this for all the .blend files (or equivalent or whatever) then open. \$\endgroup\$
    – lvictorino
    May 3, 2020 at 10:26
0
\$\begingroup\$

I encountered this issue with Unity 2021.3.26f1 and Blender 3.60. With this, saving .blend files directly in my Unity project's asset folder should have worked to import them automatically, but I was still getting the "Blender is not found" message.

Turns out Unity doesn't understand Blender Collections. I had to place my asset into the default "scene collection" collection in Blender for the model to be automatically recognized.

\$\endgroup\$
0
\$\begingroup\$

Take these steps to manually configure Unity to recognize .blend files. Firstly, confirm that Blender is installed and its path is added to the system's environment variables. After this, open Unity and go to Edit > Preferences > External Tools. Look for "Blender Executable" in the "External Tools" window and click "Browse". Locate the installation location of Blender on your computer and choose the "blender.exe" executable. Finally, click "Open". To save your changes, click "Apply" after adding ".blend" to the "External Tools" window's "File Extensions" section by clicking "Add".

Make sure you have a Blender version that works with Unity. Also, ensure both programs are running in 64-bit mode. After that, you should have no issues importing .blend files into Unity.

\$\endgroup\$

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .