1
\$\begingroup\$

Can anyone help me? I am exporting models with textures (.obj) from Crocotile3D to Unreal Engine 4. I want them to be crisp and clear, as in the left image (Crocotile editor), but only get blurry, as in the right image (Unreal editor). Whether I export the model at scale x 1 or greater doesn't make any difference. My textures are 16x16 pixels.

I have watched endless videos and tinkered with settings but been stuck for two days. Any help or advice will be much appreciated!

Crocotile3D,, Unreal Editor, Crocotile Eport Settings

\$\endgroup\$
  • 1
    \$\begingroup\$ It looks like you're using bilinear texture filtering (typical for high-res textures on 3D models, so it's normal for it to be Unreal's default) instead of point / nearest neighbour (the standard for pixel art) — do you see a place you can change that on your texture files or material once they're imported into Unreal? \$\endgroup\$ – DMGregory Apr 18 at 11:27
  • 1
    \$\begingroup\$ I found the setting, thank you so much! It was the 'texture group' setting and it had to be set to 2D. I really appreciate it because I've been stuck on this for ages. I will post the solution as an answer to this question now. \$\endgroup\$ – Sam Luxton Apr 18 at 13:01
3
\$\begingroup\$

Thanks to DMGregory I solved the problem. I will leave the answer here for others to see.

In Unreal Editor, double click your texture to open the texture editor. Then, look at the 'details' section on the right. Find the 'Level Of Detail' section and open the 'Texture Group' menu. Choose '2D Pixels (unfiltered)', and you should have nice crispy clean textures even when resizing objects.

Level Of Detail Menu

| improve this answer | |
\$\endgroup\$

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.